AnsweredAssumed Answered

CA Service Desk issue with tomcat

Question asked by VinodVishwanatham1312864 on May 30, 2016
Latest reply on Jun 7, 2016 by VinodVishwanatham1312864

Hi,

We are trying to configure CA Service Desk application on IIS server initially which is configure on tomcat server.

 

After running pdm_configure in cmd, the set up is exiting by skipping some steps. Gone through logs and found the below error in configure log.

 

The path shown in the log is related to C drive,  but the actual installation is in E Drive.

 

INFO  Task.java              214 Running: Configure Tomcat integration

05/30 11:24:31.796 ERROR InstallTomcatTask.java   150 catalina.policy: C:\PROGRA~1\CA\SERVIC~1\bopcfg\www\CATALINA_BASE\conf: The system cannot find the path specified

05/30 11:24:31.796 ERROR TomcatUtilities.java   455 IOException:C:\PROGRA~1\CA\SERVIC~1\bopcfg\www\CATALINA_BASE\conf\catalina.properties (The system cannot find the path specified)

05/30 11:24:31.796 ERROR InstallTomcatTask.java   150 context.xml: C:\PROGRA~1\CA\SERVIC~1\bopcfg\www\CATALINA_BASE\conf: The system cannot find the path specified

05/30 11:24:31.796 ERROR InstallTomcatTask.java   150 logging.properties: C:\PROGRA~1\CA\SERVIC~1\bopcfg\www\CATALINA_BASE\conf: The system cannot find the path specified

05/30 11:24:31.796 INFO  CommentAJPConnector.java    77 in = C:\Program Files\CA\SC\tomcat\6.0.30\conf\server.xml

05/30 11:24:31.796 INFO  CommentAJPConnector.java    78 out = C:\PROGRA~1\CA\SERVIC~1\bopcfg\www\CATALINA_BASE\conf\server.xml

05/30 11:24:31.812 ERROR CommentAJPConnector.java   102 C:\PROGRA~1\CA\SERVIC~1\bopcfg\www\CATALINA_BASE\conf\server.xml (The system cannot find the path specified)

Exception in thread "ConfigThread: Configure Tomcat integration" java.lang.NullPointerException

  at com.ca.ServicePlus.configui.utils.CommentAJPConnector.<init>(CommentAJPConnector.java:106)

  at com.ca.ServicePlus.configui.tasks.InstallTomcatTask.run(InstallTomcatTask.java:123)

  at com.ca.ServicePlus.wizard.task.Task.start(Task.java:215)

  at com.ca.ServicePlus.configui.ConfigThread.run(ConfigThread.java:423)

05/30 11:24:34.043 INFO  TaskMediator.java      157 Configuration has completed successfully.

 

Did some googling and found in CA Communities that the tomcat location is different and made changes accordingly in NX.env and config.properties file in site directory.

 

After making the changes, while trying to run the pdm_configure we are getting the same scenario repeated.

 

Please help with this.

 

Thanks & Regards,

Subhash

Outcomes