Chris_Hackett

Chat Transcript - CA PPM Office Hours: A Live Online Chat (August 2016)

Discussion created by Chris_Hackett Employee on Aug 11, 2016

Miss the August PPM Office Hours - Online Chat? Check out what you missed below and be sure to join us in September for the next session!

 

from Chris Hackett (CA) to Everyone:

  Hi Everyone - We'll be starting in just a few minutes.

from Chris Hackett (CA) to Everyone:

  Hi Everyone - We're waiting on a few more CA folks to join then we'll get started.

from Lowell Wetzel to Everyone:

  I am trying to import a CSV file using GEL from a "SharePoint" Document Library.  The service account has been granted rights to the library.  But, the "<file:read" command always returns "File not found".

from Chris Hackett (CA) to Everyone:

  Hi Everyone - We're going to go ahead and start but forwarned we don't have anyone from Support. They usually handle the bulk of the technical questions. We'll do what we can

from Martti K. to Everyone:

  What is the effect of changing display mappings?

If you change Idea  object priority according to TEC1571568 CLRT-79643 causes duplicate values.

Is that limited to Idea or can that happen with Status report as well?

There are three Status attributes  which have mappings for 10 20 30 and use lookup Status Report Status.

The overall status is calculated from these three and has display mappings

0 - 40

40 - 90

90 - 100

I think somebody recently asked about changing similar mapping and the answer was that there is no problem.

For the overall status I don't think you get the duplicates, because that is calculated, but are the current values updated when mappings are changed?

Or does that require some action, if so what?

In order to change the mappings of the three Status attributes you would have to create new values for the Status Report Status lookup with the desired ID's/enums and to deactivate the obsolete ones.

What I have seen that will effect the overall Status fo

from Martti K. to Everyone:

  Is it possible to get Office Hours chat transcripts into DocOps so that they would be included in search.

from John W. George (CA Technologies) to Everyone:

  Hi @Martti - are you asking us to include a link to Chris's transcript of the PPM Office Hours that he posts to the Community? Is that what you are looking for?

from Martti K. to Everyone:

  Yes

from John W. George (CA Technologies) to Everyone:

  @Martti - o.k. great suggestion. I've just written that one down. We'll see what we can do.

from Martti K. to Everyone:

  Thanks, you know there are questions asked here which are recorded nowhere else and having the chats easily searchable would bring that knowledge to more use.

from Lowell Wetzel to Everyone:

  I am trying to import a CSV file using GEL from a "SharePoint" Document Library.  The service account has been granted rights to the library.  But, the "<file:read" command always returns "File not found".  When I put the file in any other location, it finds it.  Is there something special about SharePoint Document libraries?  Has anyone else had success in reading files from SharePoint Document Libraries

from Martti K. to Everyone:

  Wll actually not just links, but the whole content of the transcripts.

from John W. George (CA Technologies) to Everyone:

  @Martti - we unfortunately cannot include the complete transcript within the documentation, but I will work with Chris to see if we can include a link.

from Martti K. to Everyone:

  Can the cointent be made searchable withthe same search which goes to Docops?

from Lowell Wetzel to Everyone:

  I have an issue with CABI 3.3 connecting to my Clarity Environment after Database patching.  It gives me a ErrorERRORRPT-0013: You do not have the proper privileges to run the report. Please contact your system admininstrator.  How do I find the cause for this? 

from Chris Hackett (CA) to Everyone:

  @Lowell We're going to need someone from Support to answer your question. We're trying to get a resource on now.

from John W. George (CA Technologies) to Everyone:

  @Martti - since the documentation search picks up content from the documentation, PPM Community Posts, and KB articles on Support, when you search in the documentation, it should pick it up and display it in the results. We would need to test it, but theoretically it "should" work

from Martti K. to Everyone:

  @John W. That is what I thought, but after trying I am not sure. Will test some more myself.

from Damon (ca) to Everyone:

  @Lowell (CABI Error): Try http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1429424.aspx or https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&cad=rja&uact=8&ved=0ahUKEwiUj-3X77nOAhXsIMAKHdDfCX4QFggjMAE&url=http%3A%2F%2Fwww.ca.com%2Fus%2Fsupport%2Fca-support-online%2Fproduct-content%2Fknowledgebase-articles%2Ftec1429424.aspx&usg=AFQjCNGEY6HvZGl4iyNsp4zJgEvpr0oSOg

from Chris Hackett (CA) to Everyone:

  @maria: from Lowell Wetzel to Everyone:

I have an issue with CABI 3.3 connecting to my Clarity Environment after Database patching.  It gives me a ErrorERRORRPT-0013: You do not have the proper privileges to run the report. Please contact your system admininstrator.  How do I find the cause for this? 

from Damon (ca) to Everyone:

  @Lowell (CABI Error) also http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1429424.aspx

from Chris Hackett (CA) to Everyone:

  @maria: from Lowell Wetzel to Everyone:

I am trying to import a CSV file using GEL from a "SharePoint" Document Library.  The service account has been granted rights to the library.  But, the "<file:read" command always returns "File not found".  When I put the file in any other location, it finds it.  Is there something special about SharePoint Document libraries?  Has anyone else had success in reading files from SharePoint Document Libraries

from Lowell Wetzel to Everyone:

  After a database patch, I have an issue with Jaspersoft Reports just "spinning" when I attempt to open them.  I can log in to the administration console, In the Administration console, it says I must "You must apply input values before the report can be displayed.

"  Has anyone encountered this and how did you fix it?

from Damon (ca) to Everyone:

  @Lowell (CABI) I meant to include this one too: https://communities.ca.com/thread/241731250

from Nika Hadzhikidi (CA) to Everyone:

  @Lowell - concerning your Jaspersoft Reports spinning - which database patch did you use, and what is your current PPM version? Do you have Jaspersoft patch applied?

from Nick Darlington (CA) to Everyone:

  @Lowell: Regarding your GEL question, I believe you received my answer to this yesterday via the issue you raised, and that in order to read a file from the disk in GEL, if GEL cannot 'see' the file then it is because the user running your bg service also cannot 'see' the file.  Is your system on unix or Windows?

from Lowell Wetzel to Everyone:

  @Nika Hadzhikidi I will need to check with our DBAs to find out which patch.  We're on Oracle 12.1.0.2 (the one compatible with CA PPM 14.3)

from Lowell Wetzel to Everyone:

  @Nick Darlington The issue is that the file is on a SharePoint Document library and SharePoint appears to have some unique "qualities" that seem to prevent the typical GEL <file:read command from working.  I was wondering if others had used SharePoint Document libraries to transfer files or if I'm alone

from Nika Hadzhikidi (CA) to Everyone:

  @Lowell - do you have Jaspersoft patch installed? We have one available which addressed multiple issues including performance. Please go ahead and install it if you don't have it. Also ensure you are on the latest PPM patch.

from Nick Darlington (CA) to Everyone:

  @Lowell: file:read is just reading from a disk or network share at a Windows networking level, SharePoint isn't going to be a factor at that moment really, and as you can access the file seperately using your own account via the same UNC path, Windows will only allow/prevent that based on permissions to the share and file in question.

from Lowell Wetzel to Everyone:

  @Nick Darlington  I logged in as the Service account to the server and was able to access the SharePoint document library location using Windows Explorer.  The files are visible through that.  The same service account runs the beacon, app, bg, nsa services

from John W. George (CA Technologies) to Everyone:

  @Martti - I've just tested the search for the Office Hours Transcript, and the search isn't returning them. I will take your idea back to my technical team, discuss it with them, and see if there is any way to do this.

from Nick Darlington (CA) to Everyone:

  @Lowell: That should be sufficient then.

from Martti K. to Everyone:

  @John W. Thanks

from John W. George (CA Technologies) to Everyone:

  @Martti - welcome

from Lowell Wetzel to Everyone:

  @Nick Darlington it "should be", but something is strange in how SharePoint stores files versus how a normal UNC path stores files

from Martti K. to Everyone:

  @Chris WOuld the community search search the Office hours chat transcripts

from Chris Hackett (CA) to Everyone:

  @Martti - I checked and the search only picks up titles and tags apparently

from Lowell Wetzel to Everyone:

  @Nika Hadzhikidi  Can you give me the link for the Jaspersoft Patch?  I don't believe we have that

from Martti K. to Everyone:

  @Chris @John W. Did we not have a discussion a while ago about full text search of the communnity content and you told me that it is full text search?

from Nika Hadzhikidi (CA) to Everyone:

  @Martti concerning your display mappings question - this defect CLRT-79643 is only with Ideas. There should not be an issue with changing Status Report Status display mappings. I have tested this previously with regards to DWH and did not see an issue. However I didn't check how the values are updated when you change the mappings. I'll check into it.

from Lowell Wetzel to Everyone:

  @Nika Hadzhikidi What are the typical troubleshooting steps for Jaspersoft?  How do I confirm the database connection is working?  Where do I confirm PPM_JASPERSOFT contents contain the reports?

from Martti K. to Everyone:

  @Nika I became painfully aware that they are not automatically updated.

from Chris Hackett (CA) to Everyone:

  @Martti - No, it would be great if it was full text search for community content but it's not. Tags and titles only. One reason to be tagging more content.

from Martti K. to Everyone:

  @Chris Tough luck, I can see communtity discussion and question being taged, but not Office hours

from Nika Hadzhikidi (CA) to Everyone:

  @Lowell - there are a couple of "Tips" posts on the communities that I'd recommend you go through, also there is a very good section in our docs:

https://docops.ca.com/ca-ppm/14-3/en/getting-started-with-advanced-reporting-with-jaspersoft

Getting started with Jaspersoft.

If your database connection is not working, you will not be able to install Jaspersoft as the installer will check the connection first thing before installing.

The reports are installed after the initial installation with the admin content-jaspersoft csk command, and then they will be available in the Jaspersoft Console as objects. I'd recommend you check the documentation, it has all this information.

from Chris Hackett (CA) to Everyone:

  @Martti - In testing just now when I search from the Jive site directly it picks up content of discussions.

from Lowell Wetzel to Everyone:

  @Martti I have had some issues with PPM 14.3 Project Gantt view.  It appears that this allows a few issues.  It allows resources to be added multiple times to the same Team.  It also allows for Tasks to lose connection to their parent Task

from Lowell Wetzel to Everyone:

  @Nika Hadzhikidi  Thanks.  My JasperSoft was working.  Then, it is not.  I'm trying to find the best troubleshooting steps

from Nika Hadzhikidi (CA) to Everyone:

  @Lowell - if you upgraded a full version in Oracle this may be an issue. Please check the jasperserver.log located in $JSTomcat\webapps\reportservice\WEB-INF\logs for the error messages.

from Martti K. to Everyone:

  @Lowell That is more for @Nika and @Nick I have not used Gantt that much. Just today there was a question in the community where the +- sign was missing indicating a problem with the parent child relation. Rstoring defautls to the Gantt resolved that.

from Lowell Wetzel to Everyone:

  @Martti - yep, I just wanted to alert you to that

from Chris Hackett (CA) to Everyone:

  OK Everyone - We're wrapping up for today. Please join us back here in September and thank you for participating!

from Martti K. to Everyone:

  @Lowell Thanks, I do have a recollection about something about being able to have the same resource in different roles in the project coming up in some version.

from Nika Hadzhikidi (CA) to Everyone:

  @Martti - can you log a communities post or a Support case on the display mappings so we can test this?

from Nika Hadzhikidi (CA) to Everyone:

  Might be working as designed but let's check it.

from Martti K. to Everyone:

  @Nika I can do that on the community

from Chris Hackett (CA) to Everyone:

  Thanks again everyone!

from Martti K. to Everyone:

  I think it is wokring as designed, but better if it were as desired.

from Martti K. to Everyone:

  Thanks

 

 

Outcomes