AnsweredAssumed Answered

rally to tfs connector ruby_setenv error 'Invalid Argument'

Question asked by 732c300a625bdf56662f4b00729dc239 on Oct 12, 2015
Rally to TFS Connector version: 4.6.0-master-27
OS:  Windows Server 2012 R2 Standard (64-bit)
Command line: rally2_tfs_connector.exe our_config.xml 10

This will run every 10 minutes for about a day, maybe two, then it will crash and error.  Here is the entire log for this run (LogLevel = Info):
-------------------------
[2015-10-11 04:18:15 Z]   ANY : RallyEIF::WRK::ConnectorRunner.block in run - processing to commence using content from our_config.xml
[2015-10-11 04:18:15 Z]   ANY : Class.read_config_file - our_config.xml last modified 2015-10-09 14:54:11 UTC, size: 3138 chars
[2015-10-11 04:18:16 Z]   ANY : RallyEIF::WRK::RallyConnection.initialize - Initializing Rally connection version 4.9.4
[2015-10-11 04:18:16 Z]  INFO : RallyEIF::WRK::RallyConnection.initialize - Rally Web Services version v2.0
[2015-10-11 04:18:16 Z]   ANY : RallyEIF::WRK::TFSConnection.initialize - Initializing Team Foundation Server connection version 4.6.0
[2015-10-11 04:18:16 Z] ERROR : RallyEIF::WRK::ConnectorRunner.initialize - Invalid argument - ruby_setenv
[2015-10-11 04:18:16 Z] ERROR : Object.exception - Message Invalid argument - ruby_setenv
[2015-10-11 04:18:16 Z] ERROR : Object.exception - Stack Trace
[2015-10-11 04:18:16 Z] ERROR : Object.block in exception - C:/Users/username/AppData/Local/Temp/2/ocr11F2.tmp/lib/ruby/gems/2.0.0/gems/rallyeif-tfs-4.6.0/lib/rallyeif/tfs/tfs_connection/tfs_connection.rb:74:in `[]='
[2015-10-11 04:18:16 Z] ERROR : Object.block in exception - C:/Users/username/AppData/Local/Temp/2/ocr11F2.tmp/lib/ruby/gems/2.0.0/gems/rallyeif-tfs-4.6.0/lib/rallyeif/tfs/tfs_connection/tfs_connection.rb:74:in `initialize'
[2015-10-11 04:18:16 Z] ERROR : Object.block in exception - C:/Users/username/AppData/Local/Temp/2/ocr11F2.tmp/lib/ruby/gems/2.0.0/gems/rallyeif-wrk-1.0.0/lib/rallyeif/wrk/connector_runner.rb:327:in `new'
[2015-10-11 04:18:16 Z] ERROR : Object.block in exception - C:/Users/username/AppData/Local/Temp/2/ocr11F2.tmp/lib/ruby/gems/2.0.0/gems/rallyeif-wrk-1.0.0/lib/rallyeif/wrk/connector_runner.rb:327:in `block in run'
[2015-10-11 04:18:16 Z] ERROR : Object.block in exception - C:/Users/username/AppData/Local/Temp/2/ocr11F2.tmp/lib/ruby/gems/2.0.0/gems/rallyeif-wrk-1.0.0/lib/rallyeif/wrk/connector_runner.rb:282:in `each'
[2015-10-11 04:18:16 Z] ERROR : Object.block in exception - C:/Users/username/AppData/Local/Temp/2/ocr11F2.tmp/lib/ruby/gems/2.0.0/gems/rallyeif-wrk-1.0.0/lib/rallyeif/wrk/connector_runner.rb:282:in `run'
[2015-10-11 04:18:16 Z] ERROR : Object.block in exception - C:/Users/username/AppData/Local/Temp/2/ocr11F2.tmp/src/bin/rally2_tfs_connector.rb:12:in `<main>'
-------------------------

I've seen this before at the end of last week.  The Connector restarts without any issue.  If I need to, I suppose I can run it with '-1' and put it in a Windows Scheduled Task to run every 10 minutes.

Outcomes