Josh_Pearson_5689

PromptSet usage within SQL VARA objects

Discussion created by Josh_Pearson_5689 on Feb 19, 2015
Latest reply on Feb 24, 2015 by Josh_Pearson_5689
Good afternoon -
Quick background:  I have extensive use of AppWorx/UC4 v8 however we just did an install of Automic v10 and I'm sort of relearning the ropes.

I was hoping to get your advice on how to achieve what I’m looking for.

I’ve created a table on our end called Parameters.  In this table, I’m containing job specific information, such as sql parameter, paths, file names, etc.  In order to get specific values from this table, I pass the business ID (client ID), process name, and parameter ID.

These are the current contents of that table, where 70000 is the business ID, 1-4 are the param ID, and ‘FederalDirectoryFile’ is the process name.

70000    1              FederalDirectoryFile       InternalFile123.txt
70000    2              FederalDirectoryFile      c:\temp\
70000    3              FederalDirectoryFile       file123.txt
70000    4              FederalDirectoryFile       ftp.site.com

I’ve created SQL VARA objects in Automic that take the business ID and process name and then query specific values.  For example, I have a variable named VARA.SQL_GET_INTERNAL_PATH which translates to this SQL block:

select value from Parameter
where businessid = &business_id#
  and processname = &process_name#
   and parameterid = 2

So, when I create my workflow, all I pass are the business ID and process name.  From there, I expect the promptsets to pass through into the variables and then to be able to substitute the VARA names in place of the actual values.

Now, when I attempt to run my workflow, it doesn’t appear as if those VARA objects are evaluating correctly.  When I look at my activation log, it’s placing null values in lieu of the correct values from the table.  It’s figuring out the business ID and Process name because I’m hard coding those on the workflow but the VARA objects aren’t getting populated:

 2015-02-19 14:02:13 - U0020206 Variable 'BUSINESS_ID#' was stored with value '70000'.
2015-02-19 14:02:13 - U0020206 Variable 'EXTERNAL_FILENAME#' was stored with value ''.
2015-02-19 14:02:13 - U0020206 Variable 'EXTERNAL_PATH#' was stored with value ''.
2015-02-19 14:02:13 - U0020206 Variable 'INTERNAL_FILENAME#' was stored with value ''.
2015-02-19 14:02:13 - U0020206 Variable 'INTERNAL_PATH#' was stored with value ''.
2015-02-19 14:02:13 - U0020206 Variable 'PROCESS_NAME#' was stored with value 'FederalDirectoryFile'.

I talked about this with my Automic consultant during the install and was told that VARA objects can contain other variables but it doesn’t look like I’m doing it correctly.  Any advice?

Thanks.

 


Outcomes