AaronArmagost

CA Tuesday Tip:  Cannot Start Daemons on Linux s390 Endpoint.

Discussion created by AaronArmagost Employee on Aug 1, 2011
This is a very common issue in CA support on newly installed s390 zLinux endpoints.

Description:

After a fresh install of CA Access Control r12.5 SPn on zLinux (s390) you are getting the following from seload.

/opt/CA/AccessControl/bin/seload
CA Access Control seload v12.53.0.1517 - Loader Utility
Copyright (c) 2010 CA. All rights reserved.
21 Dec 2010 10:06:46> WAKE_UP : Server going up
21 Dec 2010 10:06:46> INFO : Filter mask: 'WATCHDOG*' is registered
21 Dec 2010 10:06:46> INFO : Filter mask: 'INFO : Setting PV*' is
registered
21 Dec 2010 10:06:46> INFO : Filter mask: 'INFO : DB*' is registered
21 Dec 2010 10:06:46> INFO : Filter mask: '*seosd.trace*' is registered
21 Dec 2010 10:06:46> INFO : Filter mask: '*FILE*secons*(*/log/*)*' is
registered
Starting seosd. PID = 10808.
Checking database ...
/opt/CA/AccessControl/bin/seagent: /opt/CA/AccessControlShared/JavaStubs/bin/libjvm.so: no
version information available (required by /opt/CA/AccessControl/bin/seagent)
/opt/CA/AccessControl/bin/seagent: /opt/CA/AccessControlShared/JavaStubs/bin/libjsig.so: no
version information available (required by /opt/CA/AccessControl/bin/seagent)
/opt/CA/AccessControl/bin/seagent: relocation error: /opt/CA/AccessControl/bin/seagent: symbol
sigaction, version JSIG_2.3 not defined in file libjsig.so with link time
reference
Not all daemons are loaded, operation timed out


To solve this you will need to install the 32bit version of Java for zLinux and verify that the java_home configuration setting in the global section of the accommon.ini file contains the path to the Java environment.

For example, java_home=/opt/ibm/java2-s390-50/jre.

You might also need to set the value of the LD_LIBRARY_PATH environment variable to the path used by the shared libraries of the Java environment.

Thanks,

Aaron Armagost
Sr. Support Engineer

Outcomes