upgrade from 8.1 to 12.1.3 issue

Discussion created by dshaffer on May 3, 2012
Latest reply on May 10, 2012 by Chris_Hackett
PROBLEM: Upgrade of Clarity from current version: to states it completes "BUILD SUCCESSFUL", however I'm prompted for a unknown password, and I am not able to start the services. See an excerpt of the control terminal below.

CA Support stated that the account used to install Clarity required sudo, root rights. In the past this was not a requirement for our organization and was under the assumption that sudo rights were only needed when the Beacon service is uses for clustered server configurations. Anyhow, I now have re-installed/upgraded again with sudo access rights for the application user and I'm still getting the same outcome.

If anyone has seen this I would appreciate some feedback.

<START - Excerpt of the control terminal at end of upgrade>
Total time: 232 minutes 12 seconds
Starting Beacon
/usr/bin/id: illegal option -- u
Usage: id [-ap] [user]
su: Sorry
Starting NSA
Adding service(s)...
All services are already registered.
/usr/bin/id: illegal option -- u
Usage: id [-ap] [user]
su: Sorry


<START - Excerpt of parameters for upgrade>

-logbash-2.05b$ pwd
-logbash-2.05b$ sh install.sh
Buildfile: ./gateway.xml

Trying to override old definition of task java


Clarity Home Directory [niku/clarity] :
You chose the following:

install.dir = /niku/clarity


Current version:
Upgrading to:


Before proceeding, please make sure to do the following:
- For upgrades: Read the upgrade section in the
installation guide thoroughly.
- For fix packs: Read the installation instructions
in the release release notes thoroughly.
- Make sure to perform this upgrade first on a test
environment with a replication of your production data.

Type 'y' to proceed : y



J2SDK 1.6.0 (or higher) Home Directory [usr/local/java] :

Beacon Multicast Address [] :

Beacon Multicast Port [9090] :

Beacon Client Port [9091] :

Use command prefix such as sudo for superuser tasks? [no] : yes

Superuser Command Prefix : sudo

User name for superuser tasks [root] : niku

J2EE Server Vendor
1) Apache Tomcat
2) Generic J2EE

Choose option [1]: 1

Install Clarity System Administrator Application (CSA)? [true] :

Tomcat Home Directory [niku/apache-tomcat-5.5.17] : /niku/

Error: Invalid Tomcat home directory.

Tomcat Home Directory [niku/apache-tomcat-5.5.17] : /niku/apache-tomcat-6.0.26

CSA Web Port [8090] :
You chose the following:

java_home = /usr/local/java
nsa.multicast.address =
nsa.multicast.port = 9090
nsa.client.port = 9091
use.command.prefix = yes
command.prefix = sudo
root.user = niku
j2ee.vendor = tomcat
nsa.install = true
j2ee.home = /niku/apache-tomcat-6.0.26
nsa.web.port = 8090
Use these settings? [(y)es, (n)o] y


* Solaris 10 application server
* Single instance of Clarity
* Oracle database
* Java version (build 1.6.0_30-b12)
* Tomcat version: apache-tomcat-6.0.26

I've created a case with CA Support on this issue and have not made much progress on this this issue.