AnsweredAssumed Answered

Question on the @bouser command and security not working properly-

Question asked by vtleogal2 on Oct 19, 2012
Latest reply on Dec 7, 2012 by Chris_Hackett
I posted this on linkedin also, but I wanted to cover it here as well: We just recently had all of our Universes built, and I am in the validation stage: (thus this is not in prod yet)


Question on the @bouser command that Webi is using. How do I correct this security issue?
I am the admin in Clarity and my login to Webi is the same as my login to Clarity. In Webi. I am part of the Clarity Admin group as well as Bus Objects.

I am in our test environment, and when I run a simple report of project id and project name for two different projects, all is fine- id and name show

However, I then add in a custom attribute (all are built in the Universe) and one project works just fine.. (data shows) but another project yields the no data to retrieve message. The project giving the error is one I created in Clarity (Among many others), but regardless, I have full security access. the query generated in Webi is identical for both projects. I know that in 12.1 (our version of Clarity), the system started using the @variable ('BOUSER') command in Webi and I think that is supposed to pass the id from Clarity?
Anyway, has anyone run into this? Why would it not give me data to projects in Webi that I have full access to in Clarity? I have searched information on CA, the web, forums, etc and I cannot find anything that relates to this specific issue and a given solution. I did see something about the Bouser on here, but it did not help my situation.

Any ideas??
Let me know if I need to provide more information.
Thanks
Lynn


12.1 Clarity

Outcomes